194 7 LINKEDINCOMMENTMORE

LINDA – Residents of Casa Mia mobile home park in Linda, outside of Marysville, claim the park owner and manager have failed to repair failed electricity lines, leaving their homes without heat for four weeks.

"We put extra blankets on the bed. We have a little bathroom heater," said Randy Flewellen, one of five homeowners without heat.

The homes are without heat because one of the two 110 amp lines running to their homes is no longer working. So the homes have some power, but large appliances, such as furnaces, need 220 amps to run.

Monday morning, Flewellen showed off the inconvenient extension cord running from his living room to his kitchen to keep his refrigerator operating. He said that's been the situation for four weeks as of Monday.

Residents in the other homes are afraid to speak publically for fear of retaliation from park management.

"You don't want me to get kicked out of here," one said. "If I talk, I'd be out."

The manager on site refused to open his door when asked about the issue, but said an underground surge caused the problem. When asked how long ago, he said, "It's none of your business."

The park owner, identified as Orezt Wesley, later called to say a company would be fixing the faulty 110 amp line by the end of the week. When pressed on why he didn't call a company that could make repairs sooner, he said he "called around."

Wesley also said, "I'm going to get an extension cord to power their furnace."

Residents want a definitive answer.

"We're just sitting here, wondering if we're going to have power tomorrow or not," said Flewellen.

News10 notified the mobile home ombudsman in the California Department of Housing and Community Development. The ombudsman has the authority to ensure proper actions are taken to repair electrical lines.

194 7 LINKEDINCOMMENTMORE
Read or Share this story: http://on.news10.net/1ejZMHm